Skip to main content
← All vulnerabilities
CVE-2023-51437GHSA-C57V-4VG5-CM2X

Apache Pulsar: Timing attack in SASL token signature verification

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.11.3, 3.0.2, 3.1.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Pulsar

    through 2.10.5; From 2.11.0 · through 2.11.2; From 3.0.0 · through 3.0.1

  • org.apache.pulsar:pulsar-broker-auth-saslMaven

    fixed in 2.11.3

  • org.apache.pulsar:pulsar-broker-auth-saslMaven

    From 3.0.0 · fixed in 3.0.2

  • org.apache.pulsar:pulsar-broker-auth-saslMaven

    From 3.1.0 · fixed in 3.1.1

References 2

lists.apache.org

openwall.com