CVE-2023-49736PYSEC-2026-1184BIT-SUPERSET-2023-49736GHSA-JFXJ-XF67-X723
Apache Superset: SQL Injection on where_in JINJA macro
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.1.2, 3.0.2, 2.1.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Superset
fixed in 2.1.2; From 3.0.0 · fixed in 3.0.2
- apache-supersetPyPI
fixed in 2.1.3; From 3.0.0 · fixed in 3.0.2
- apache-supersetPyPI
fixed in 2.1.3
- apache-supersetPyPI
From 3.0.0 · fixed in 3.0.2