Skip to main content
← All vulnerabilities
CVE-2023-49295GHSA-PPXX-5M9H-6VXFGO-2024-2459

quic-go's path validation mechanism can cause denial of service

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.39.4, 0.38.2, 0.37.7, 0.40.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • quic-go quic-go

    From 0.39.0 · fixed in 0.39.4; From 0.38.0 · fixed in 0.38.2; fixed in 0.37.7

  • github.com/quic-go/quic-goGo

    From 0.40.0 · fixed in 0.40.1

  • github.com/quic-go/quic-goGo

    From 0.39.0 · fixed in 0.39.4

  • github.com/quic-go/quic-goGo

    From 0.38.0 · fixed in 0.38.2

  • github.com/quic-go/quic-goGo

    fixed in 0.37.7

  • github.com/quic-go/quic-goGo

    fixed in 0.37.7; From 0.38.0 · fixed in 0.38.2; From 0.39.0 · fixed in 0.39.4; From 0.40.0 · fixed in 0.40.1

References 11

GitHub · quic-go/quic-go

lists.fedoraproject.org