CVE-2023-49145GHSA-68PR-6FJC-WMGMBIT-NIFI-2023-49145
Apache NiFi: Improper Neutralization of Input in Advanced User Interface for Jolt
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.24.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.
Timeline
- CVE published
- Record last updated
Affected versions
- org.apache.nifi:nifi-jolt-transform-json-ui
From 0.7.0 · through 1.23.2
- org.apache.nifi:nifi-jolt-transform-json-uiMaven
fixed in 1.24.0