Skip to main content
← All vulnerabilities
CVE-2023-4785PYSEC-2026-1428GHSA-P25M-JPJ4-QCRR

Denial of Service in gRPC Core

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.55.3, 1.54.3, 1.53.2, 1.56.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. Linux) allows an attacker to cause a denial of service by initiating a significant number of connections with the server. Note that gRPC C++ Python, and Ruby are affected, but gRPC Java, and Go are NOT affected.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Google gRPC

    From 1.56.0 · through 1.56.1; From 1.55.0 · through 1.55.2; From 1.54.0 · through 1.54.2; From 1.53.0 · through 1.53.1

  • grpcioPyPI

    From 1.55.0 · fixed in 1.55.3; From 1.54.0 · fixed in 1.54.3; From 1.53.0 · fixed in 1.53.2

  • grpcRubyGems

    From 1.56.0 · fixed in 1.56.2

  • grpcRubyGems

    From 1.55.0 · fixed in 1.55.3

  • grpcRubyGems

    From 1.54.0 · fixed in 1.54.3

  • grpcRubyGems

    From 1.53.0 · fixed in 1.53.2

  • grpcioPyPI

    From 1.55.0 · fixed in 1.55.3

  • grpcioPyPI

    From 1.54.0 · fixed in 1.54.3

  • grpcioPyPI

    From 1.53.0 · fixed in 1.53.2

References 5

GitHub · grpc/grpc