Skip to main content
← All vulnerabilities
CVE-2023-47635GHSA-F3QM-VFC3-JG6V

Decidim vulnerable to possible CSRF attack at questionnaire templates preview

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.27.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Decidim is a participatory democracy framework. Starting in version 0.23.0 and prior to versions 0.27.5 and 0.28.0, the CSRF authenticity token check is disabled for the questionnaire templates preview. The issue does not imply a serious security thread as you need to have access also to the session cookie in order to see this resource. This URL does not allow modifying the resource but it may allow attackers to gain access to information which was not meant to be public. The issue is fixed in version 0.27.5 and 0.28.0. As a workaround, disable the templates functionality or remove all available templates.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • decidim decidim

    From 0.23.0 · fixed in 0.27.5

  • decidim-templatesRubyGems

    From 0.23.0 · fixed in 0.27.5

References 8

GitHub · decidim/decidim