Skip to main content
← All vulnerabilities
CVE-2023-46801GHSA-JJVC-V8GW-5255

Apache Linkis DataSource: DataSource Remote code execution vulnerability

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.6.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

In Apache Linkis <= 1.5.0, data source management module, when adding Mysql data source, exists remote code execution vulnerability for java version < 1.8.0_241. The deserialization vulnerability exploited through jrmp can inject malicious files into the server and execute them. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out.  We recommend that users upgrade the java version to >= 1.8.0_241. Or users upgrade Linkis to version 1.6.0.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • org.apache.linkis:linkis-metadata-query-service-jdbc

    From 1.4.0 · fixed in 1.6.0

  • org.apache.linkis:linkis-datasourceMaven

    From 1.4.0 · fixed in 1.6.0

References 1

lists.apache.org