Skip to main content
← All vulnerabilities
CVE-2023-46734GHSA-Q847-2Q57-WMR3BIT-SYMFONY-2023-46734

Symfony potential Cross-site Scripting vulnerabilities in CodeExtension filters

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.4.51, 5.4.31, 6.3.8
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Starting in versions 2.0.0, 5.0.0, and 6.0.0 and prior to versions 4.4.51, 5.4.31, and 6.3.8, some Twig filters in CodeExtension use `is_safe=html` but don't actually ensure their input is safe. As of versions 4.4.51, 5.4.31, and 6.3.8, Symfony now escapes the output of the affected filters.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • symfony symfony

    From 2.0.0 · fixed in 4.4.51; From 5.0.0 · fixed in 5.4.31; From 6.0.0 · fixed in 6.3.8

  • symfony/twig-bridgePackagist

    From 2.0.0 · fixed in 4.4.51

  • symfony/twig-bridgePackagist

    From 5.0.0 · fixed in 5.4.31

  • symfony/twig-bridgePackagist

    From 6.0.0 · fixed in 6.3.8

  • symfony/symfonyPackagist

    From 2.0.0 · fixed in 4.4.51

  • symfony/symfonyPackagist

    From 5.0.0 · fixed in 5.4.31

  • symfony/symfonyPackagist

    From 6.0.0 · fixed in 6.3.8

References 4

GitHub · symfony/symfony

lists.debian.org